System Workbench for STM32

Debugger just stopped working.

I’ve been using the debugger for months without a single problem.

I’m working on two cards that are communicating tegether via CAN. I swtich between the two making changes and debugging, no problem.

Today I had to go to a meeting with my computer so (carefully) unplugged the STLink and serial port.
Came back from the meeting plugged everything back in and it “times out” after bulk erase.

I checked to make sure that there aren’t any unclosed exe’s running, Reset Eclipse, re-double checked debug connections. Nothing works. I shouldn’t have to change timeout values as these worked “as is” before.

It does the same thing on both boards. I loaded the program with the serial port and it worked fine, no problem with the boards.



Newest Forum Posts

  1. Nucleo-144 TCP Problems by mklee, 2019-03-22 19:25
  2. CubeMX function pack development by ajcurtis84, 2019-03-22 18:59
  3. STM32CubeMX LWIP not working by leflingue, 2019-03-22 12:22
  4. STM32CubeMX LWIP not working by matsjuhlin, 2019-03-22 09:13
  5. STM32F746-Discovery by stanandrzej, 2019-03-21 12:41
  6. System Workbench takes up to five minutes to load by Servant, 2019-03-21 02:39
  7. How to use multiple ST boards simultaneously by Kevarek, 2019-03-20 19:21
  8. How to debug STM32f103c8t6 with stm link utility by jcliff, 2019-03-20 15:36
  9. PWM signal Output Malfunctionment by Michael zeinoun, 2019-03-19 11:20
  10. What different WINDOWS MAC OS by actionprog, 2019-03-19 06:08

Last-Modified Blogs