System Workbench for STM32

Run valgrind in STM32 ide

Hi STM32 community, I want to run valgrind on my project. I am system workbench IDE for STM32F779I eval board.

Can any body help me how can I run valgrind on my project.

I have seen a profile with valgrind option in the project options. But when I tried this option,

it is giving following error

valgrind: failed to start tool ‘memcheck’ for platform ‘arm-linux’: No such file or directory

I checked about this error in google , people suggested to set the valgrind library. But it is giving same error .

Can anyone help me how to solve this issue or how can I run valgrind with different way.


Newest Forum Posts

  1. Nucleo-144 TCP Problems by mklee, 2019-03-22 19:25
  2. CubeMX function pack development by ajcurtis84, 2019-03-22 18:59
  3. STM32CubeMX LWIP not working by leflingue, 2019-03-22 12:22
  4. STM32CubeMX LWIP not working by matsjuhlin, 2019-03-22 09:13
  5. STM32F746-Discovery by stanandrzej, 2019-03-21 12:41
  6. System Workbench takes up to five minutes to load by Servant, 2019-03-21 02:39
  7. How to use multiple ST boards simultaneously by Kevarek, 2019-03-20 19:21
  8. How to debug STM32f103c8t6 with stm link utility by jcliff, 2019-03-20 15:36
  9. PWM signal Output Malfunctionment by Michael zeinoun, 2019-03-19 11:20
  10. What different WINDOWS MAC OS by actionprog, 2019-03-19 06:08

Last-Modified Blogs