Loading...
 

STM32MP1 support available in SW4STM32

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4; you can download a short video showcasing this on the ac6-tools website (registration required).

System Workbench for STM32


Install 32 bit ubuntu 18.04 Java version error

Hi, during installation script execution I get an error
“Your JavaRE version is 11.0.3, System Workbench requires at least version 1.7.0.
Please download and install JavaRE 7 (32 bits) or newer version.
Go to http://www.oracle.com/technetwork/java/javase/downloads/index.html"Question

Well to a human my Java is up to date and far in advance of your requirement, so what is wrong please ? and can anybody suggest a workaround ?

Needless to say I am not at all impressed with this forum!

However for any other poor soul stuck with this it is necessary to downrev JAVA, I found 8 worked ok, I suspect the 32bit software has a bug dealing with double digit numbers.


Hi,

Sorry for answering you late. As written on the download page, the 32bits version of System Workbench is no longer maintained due to incompatibility issues. The latest version was release in April 2017 when java highest version was 1.8.0.

Indeed you are right about the 2 digit problem as it was not expected from Oracle to jump from 1.8.0 to 11.0.3. This problem was fixed on the Linux 64bits installer but still remained on the older 32bits installer.

Sorry again for the troubles you experienced.

Regards,
Kevin