Loading...
 

System Workbench for STM32


Crashes of Workbench on Mac 10.14 (Mojave)

Hello,
since upgrading to Mac 10.14 (Mojave)
Workbench exits many times in different situations:
deleting text, compiling, starting debugging, cut out text.
I used the latest installer of Workbench, not the beta version:
Version: Neon.3 Release (4.6.3)
Build id: 20170314-1500
JRE is: Java(TM) SE Runtime Environment (build 1.8.0_144-b01)
I recommend others not to upgrade to Mojave.

Apple offers a new release 10.14.1.
This seems to be fine. No crashes anymore.

How has 10.14.1 been acting with workbench in the past month you’ve been using it? Pretty stable now? I need to update my Xcode, but unfortunately it would require me to update my Mac OS. Trying to better gauge how bad workbench is with 10.14.

This has been a known bug of Eclipse Neon for some time.

If you are having stability, that’s good, although Eclipse Neon is not guaranteed to be stable on 10.13 or 10.14. If you find that the instability re-occurs, the only real fix is to install Eclipse Oxygen, and then install SystemWorkbench from within Eclipse. Unfortunately, this is a suboptimal solution as the debugger isn’t fully functional.

So we will need to wait until OpenSTM32 group migrates to Eclipse Oxygen for full stability and support.


Not sure if this will help you ... I use latest version of Workbench with Eclipse Photon on Mac 10.14.1 and have no instability. I have two (large) projects, using different boards from STM32CubeMX generated projects.
Did you install System Workbench for STM32 with installer or from Eclipse?

Hi,

To install System Workbench for STM32 with the latest Eclipse version you have to install it from Eclipse. (For now ,the System Workbench for STM32 installer provides an Eclipse NEON version only)

You have to install :
- Eclipse Photon C/C++ Development for MACOS 64bits : https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/2018-12/R/eclipse-cpp-2018-12-R-macosx-cocoa-x86_64.dmgQuestion

- ST-Link Server for multiple target debug (optional) : https://www.st.com/en/development-tools/st-link-server.htmlQuestion

Then follow the steps on http://www.openstm32.org/Installing%2BSystem%2BWorkbench%2Bfor%2BSTM32%2Bfrom%2BEclipseQuestion

Regards,
Kevin.


 

Newest Forum Posts

  1. Nucleo-144 TCP Problems by mklee, 2019-03-22 19:25
  2. CubeMX function pack development by ajcurtis84, 2019-03-22 18:59
  3. STM32CubeMX LWIP not working by leflingue, 2019-03-22 12:22
  4. STM32CubeMX LWIP not working by matsjuhlin, 2019-03-22 09:13
  5. STM32F746-Discovery by stanandrzej, 2019-03-21 12:41
  6. System Workbench takes up to five minutes to load by Servant, 2019-03-21 02:39
  7. How to use multiple ST boards simultaneously by Kevarek, 2019-03-20 19:21
  8. How to debug STM32f103c8t6 with stm link utility by jcliff, 2019-03-20 15:36
  9. PWM signal Output Malfunctionment by Michael zeinoun, 2019-03-19 11:20
  10. What different WINDOWS MAC OS by actionprog, 2019-03-19 06:08

Last-Modified Blogs