Loading...
 

System Workbench for STM32


ST-Link V2 with Eclipse debugging issue

HI,
I am using Eclipse , ST-Link V2 and GDB OpenOCD
When I run the debug, I see this error:

‘’Open On-Chip Debugger 0.10.0 (2018-07-28) https://github.com/sysprogs/openocdQuestion
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
User : 13 1 command.c:544 command_print(): debug_level: 3
Unexpected command line argument: Files\GNU’’



Untitled


Is there any problem in my setting?

Hi,

This forum is dedicated to System Workbench for STM32. You are working on a different IDE, so you might find better answer on your product website.

Anyway, the error message seems to indicate that GDB can’t be found. You should maybe select the gdb executable from the Browse button.

Regards,
Kevin


 

Newest Forum Posts

  1. Nucleo-144 TCP Problems by mklee, 2019-03-22 19:25
  2. CubeMX function pack development by ajcurtis84, 2019-03-22 18:59
  3. STM32CubeMX LWIP not working by leflingue, 2019-03-22 12:22
  4. STM32CubeMX LWIP not working by matsjuhlin, 2019-03-22 09:13
  5. STM32F746-Discovery by stanandrzej, 2019-03-21 12:41
  6. System Workbench takes up to five minutes to load by Servant, 2019-03-21 02:39
  7. How to use multiple ST boards simultaneously by Kevarek, 2019-03-20 19:21
  8. How to debug STM32f103c8t6 with stm link utility by jcliff, 2019-03-20 15:36
  9. PWM signal Output Malfunctionment by Michael zeinoun, 2019-03-19 11:20
  10. What different WINDOWS MAC OS by actionprog, 2019-03-19 06:08

Last-Modified Blogs