Loading...
 

STM32MP1 support available in SW4STM32

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4; you can download a short video showcasing this on the ac6-tools website (registration required).

System Workbench for STM32


STM32L4 Support in System Workbench

Hi,
I noticed there’s still no support for the STM32L4 on the latest version of AC6 System Workbench v1.2. Do you have a timeframe when System Workbench will include L4 support?

Thanks,
Joe T

France

Hi,
Version 1.3 was out since this morning, with support for the STM32L4 chips :-) The announcement gets out just minutes after your mail...
Best regards,
The Ac6 OpenSTM32 team

Thanks for the notice. I upgraded to v1.3 after you told me and I’m able to build just fine, but I’m having issues with the debugger. When I go to launch the debugger, I get a pop up window with the following message:

‘Launching Exp1 Configuration.elf’ has encountered a problem.

Error with command:
arm-none-eabi-arm-none-eabi-\gdb - - version

Cannot run program “arm-none-eabi-arm-none-eabi-\gdb”: Launching failed


Any sugggestions for getting passed this issue?

Thanks,
Joe T

Where do I finde a changelog for this update?
where do I finde the anouncement for this update?

regards!


Hi Joe T,

Some debug configuration created on previous seems corrupted in the v1.3. We are investigating on it.

To manually correct this, please replace the GDB Command from your “Ac6 STM32 Debugging” debug configuration (in Run > Debug Configurations...> Your config name > Debugger) by ${openstm32_compiler_path}\arm-none-eabi-gdb

You should not find this bug again with newly created debug configuration.

Regards,
Kevin.