Loading...
 

STM32MP1 support available in SW4STM32

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4; you can download a short video showcasing this on the ac6-tools website (registration required).

System Workbench for STM32


Release fail to run

I’m trying to run a compiled release on STM32F756 on latest AC6 version .
I get this message
Open On-Chip Debugger 0.10.0-dev-00019-g5352c55 (2019-02-14-15:45)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
srst_only separate srst_nogate srst_open_drain connect_assert_srst
Info : The selected transport took over low-level target control. The results might differ compared to plain JTAG/SWD
adapter speed: 4000 kHz
adapter_nsrst_delay: 100
Info : clock speed 4000 kHz
Info : STLINK v2 JTAG v32 API v2 SWIM v7 VID 0x0483 PID 0x3748
Info : vid/pid are not identical: 0x0483/0x374B 0x0483/0x3748
Info : using stlink api v2
Info : Target voltage: 3.085489
Info : Stlink adapter speed set to 4000 kHz
Info : STM32F765IGHx.cpu: hardware has 8 breakpoints, 4 watchpoints
target halted due to debug-request, current mode: Thread
xPSR: 0x01000000 pc: 0xfffffffe msp: 0xfffffffc

    • Programming Started **

auto erase enabled
Info : flash size probed value 1024
Info : Padding image section 0 with 488 bytes
wrote 458752 bytes from file Release22/4200.elf in 6.038865s (74.186 KiB/s)

    • Programming Finished **
    • Verify Started **

target halted due to breakpoint, current mode: Thread
xPSR: 0x61000000 pc: 0x2000002e msp: 0xfffffffc
target halted due to breakpoint, current mode: Thread
xPSR: 0x61000000 pc: 0x2000002e msp: 0xfffffffc
verified 250640 bytes in 0.330055s (741.590 KiB/s)

    • Verified OK **
    • Resetting Target **

shutdown command invoked

The program will not run and on the debug console I get Terminated value 0>opencd.
On the startup of the configuration I have as shown on the attached file.
Any ideas.

Thank you.

 

Newest Forum Posts

  1. Build fails when running through command line by rangpava, 2019-05-17 19:29
  2. SWD option gone by dangermouse, 2019-05-17 17:22
  3. syscalls and STM32CubeMX by CHAABANI Ameny, 2019-05-17 17:11
  4. Problem verifing and downloading code by elvarliiv, 2019-05-17 12:05
  5. Problem verifing and downloading code by asierdo, 2019-05-17 11:50
  6. STM32 System Workbench File Opening as Text File. by ArjunSingh, 2019-05-17 08:02
  7. Issue snprintf floats by ArminOonk, 2019-05-16 16:15
  8. Issue snprintf floats by ArminOonk, 2019-05-16 16:01
  9. Adding new Include files by Mohd Tanveer, 2019-05-16 07:51
  10. UNPLUGGED TARGET DURING DEBUG SESSION , ERROR IN FINAL LAUNCH SEQUENCE by dbdb, 2019-05-16 06:44

Last-Modified Blogs