Loading...
 

STM32MP1 support available in SW4STM32

   With System Workbench for Linux, Embedded Linux on the STM32MP1 family of MPUs from ST was never as simple to build and maintain, even for newcomers in the Linux world.
And, if you install System Workbench for Linux in System Workbench for STM32 you can seamlessly develop and debug asymmetric applications running partly on Linux, partly on the Cortex-M4; you can download a short video showcasing this on the ac6-tools website (registration required).

System Workbench for STM32


You are viewing a reply to Updating Cube HAL firmware  

Updating Cube HAL firmware

I had the same problem with the latest downloaded stm32workbench -and fixed it-, Initially I was forced to use old cube version 1.7.0 (with HAL version 1.3.2). The ST website has a new cube version 1.10.0 (with HAL 1.4.2).

However stm32workbench/eclipse notified me that updates were available. A further check-for-updates in the help menu revealed that openstm32 workbench/IDE/Debug could be updated from 1.3.x.x to 1.6.x.x. So I updated these 3 components -one at a time- and hey presto stm32cube version 1.10.0 was downloaded when I next created a new project, in a new workspace.

It was necessary/sensible to create a new workspace because the name given to the HAL (hardware abstraction layer) library project was identical for both versions of stm32cube.

Everything worked well - all I had to do was follow the advice to get the updates. And use some common sense. Good work folks. Thanks.

hello
why STM32Cube MCU Package for STM32F1 series not available for download?
my project can’t generated